[ase-users] Calculator interface proposal
Jens Jørgen Mortensen
jensj at fysik.dtu.dk
Fri Feb 15 11:39:59 CET 2013
Hi!
I think the proposal is almost there now. There is also an
implementation of the base-classes that has been tested on the EMT,
NWChem, Abinit and GPAW calculators.
https://wiki.fysik.dtu.dk/ase/development/proposals/calculators.html
https://trac.fysik.dtu.dk/projects/ase/browser/branches/aep1/ase/calculators/calculator.py
What is still not quite there is the way we handle restarting old
calculations and how we specify names of files. The proposal and
implementation currently works like this:
calc = ABC(label=..., iomode='rw', output=None)
The meaning of label can be "restart from" or "write to" depending on
iomode ('r', 'w' or 'rw'). The output parameter can be used to write to
a different file than the one you are restarting from. This may be a bit
confusing - I don't know what you guys think? What happens if the input
file is missing or corrupt?
An alternative that I think is easier to understand is this:
ABC(restart=None, output=None, ignore_bad_or_missing_input=False)
I think this should work for everyone. A restart would go like this:
ABC('abc') and fail if the file is bad or missing. A fresh calculation
can be done with ABC(output='abc') and so on ...
A shorter name for ignore_bad_or_missing_input would be nice!
Please tell me what you think. I've been staring at this for quite some
time, so if you can think outside the box and come up with something
better then that would be great.
Jens Jørgen
More information about the ase-users
mailing list